nixcfg/hosts/common/services/appimage.nix
nomadics9 16170bdebc init
2024-10-06 19:48:10 +03:00

17 lines
274 B
Nix

{ config
, lib
, ...
}:
with lib; let
cfg = config.common.services.appimage;
in
{
options.common.services.appimage.enable = mkEnableOption "enable appimage";
config = mkIf cfg.enable {
programs.appimage = {
enable = true;
binfmt = true;
};
};
}